Opened 11 years ago

Closed 7 years ago

Last modified 7 years ago

#4547 closed bug (wontfix)

IE6: CSS for icon does not work properly

Reported by: srabouin Owned by:
Priority: minor Milestone: 1.9.0
Component: [meta] ui.themeroller Version: 1.7.1
Keywords: ie6 css icon Cc:
Blocked by: Blocking:

Description

.ui-accordion .ui-accordion-header .ui-icon { position: absolute; left: .5em; top: 50%; margin-top: -8px; }

the top 50% does not work properly in IE6. It will sometimes show in the proper location, but depending on the page height it will disappear from the visible area.

Unfortunately I am not a CSS expert, but I suppose a line-height would need to be specified or the top would need to be hardcoded to something like .1em, etc.

This issue also appears on the demo page for the open dialog button icon, which is using the same top: 50%.

Attachments (1)

jqueryuiiconbug.png (33.3 KB) - added by srabouin 11 years ago.
Screenshot showing the icon being placed in the wrong location when top: 50% is used

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by srabouin

Attachment: jqueryuiiconbug.png added

Screenshot showing the icon being placed in the wrong location when top: 50% is used

comment:1 Changed 11 years ago by Jörn Zaefferer

Component: ui.accordion[meta] ui.themeroller
Milestone: TBD1.8
Priority: minortrivial

Your screenshot doesn't show any relation to the accordion. And the accordion demo works fine in IE6, its just that button that is broken.

comment:2 Changed 7 years ago by Scott González

Priority: trivialminor

comment:3 Changed 7 years ago by Scott González

Resolution: wontfix
Status: newclosed

This is a bug on the ThemeRoller page, not in the CSS framework, and we're not going to support IE6 for out web sites anymore, as it only accounts for 0.1% of our traffic.

comment:4 Changed 7 years ago by Scott González

#4132 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.