Opened 10 years ago

Closed 7 years ago

#4575 closed bug (fixed)

Dialog: Scrollbar is difficult to use with overflow content and resize handle

Reported by: eriz Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.dialog Version: 1.9.0
Keywords: dialog Opera overflow Cc:
Blocked by: Blocking:

Description

When content inside dialog overflows it, scrollbar becames unusable in Opera 9.6x. My friend has confirmed this bug on his computer.

Dialog is usable - resizable, draggable but I can't drag scrollbar, it receives only click event, not drag... I didn't do any researches but I think it can be caused by resizing grip on edge of dialog.

Here's the recording which shows this behaviour: http://www.divshare.com/download/4677241-305

On Firefox everything is ok except the fact that scrollbar button is under sizing grip but it's acceptable. [;

Attachments (2)

ui.dialog-opera-scroll.patch (4.2 KB) - added by Mikko Rantanen 10 years ago.
ui.dialog patch for ticket #4575
ui.dialog-opera-scroll-and-overlay.patch (4.9 KB) - added by Mikko Rantanen 10 years ago.
ui.dialog patch for ticket #4575 with overlay handling

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by eriz

This bug happens on Opera 10 too.

comment:2 Changed 10 years ago by eriz

comment:3 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.8

comment:4 Changed 10 years ago by Mikko Rantanen

This is an advanced case of http://dev.jqueryui.com/ticket/3193

Doing the saveScroll on all elements inside the dialog solves the issue for clicks but the scroll nub is undraggable. Guess the solution is to modify the z-index of other dialogs.

Changed 10 years ago by Mikko Rantanen

ui.dialog patch for ticket #4575

Changed 10 years ago by Mikko Rantanen

ui.dialog patch for ticket #4575 with overlay handling

comment:5 Changed 10 years ago by Mikko Rantanen

The first patch fixes the immediate problem. It doesn't really bother with overlays. The second patch contains the first one plus tries to sort out the overlays as well. Not completely sure whether it maintains proper state for dialog.overlay.maxZ.

With quick testing the second patch behaved good with overlays and modal dialogs save for bug #4598.

comment:6 Changed 9 years ago by MarcoSarti

I apologize for my English but I'm not very good at writing and I just joined the site. I found this bug I have with all browsers programming with asp.net. I work out with these two lines of code after the call to the dialog:

$('.ui-widget-overlay').css('width', '100%'); 
$('.ui-widget-overlay').css('height', '100%');

The problem of line 393 to line 396 about the source of production of jquery-ui because it tries to calculate the size to be assigned to class background when simply set to 100%.

Thank you for your attention and good navigation to all.

Marco Sarti

comment:7 Changed 7 years ago by Scott González

Milestone: 1.9.01.10.0

comment:8 Changed 7 years ago by dcarrith

Summary: Dialog with overflow causes scrollbar unusableDialog: overflow causes scrollbar to be unusable

comment:9 Changed 7 years ago by bchiasson

Keywords: dialog Opera overflow added
Priority: majorminor
Status: newopen
Summary: Dialog: overflow causes scrollbar to be unusableDialog: Scrollbar is difficult to use with overflow content and resize handle
Version: 1.7.11.9.0

Execute the jsfiddle below and click the down arrow in the scrollbar. The user has to be precise and click the upper, left corner of the down arrow button in order to scroll due to the resize window icon (the behavior is observed in (IE9, Chrome 22.0.1229.94 m, Opera 12.02, Firefox 16.0.1).

http://jsfiddle.net/bchiasson/Lfx8J/5/

comment:10 Changed 7 years ago by Scott González

Resolution: fixed
Status: openclosed

Dialog: Adjust southeast resize handle to not be visible and more closely match other resize handles. Fixes #4575 - Dialog: Scrollbar is difficult to use with overflow content and resize handle.

Changeset: 1ed853f7bb9f58af09e55e207534ecb10bcbe286

Note: See TracTickets for help on using tickets.