Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#4691 closed bug (fixed)

The datepicker positioning is off if the window has almost the same height as the calendar div.

Reported by: endorielle Owned by:
Priority: minor Milestone:
Component: ui.datepicker Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have a page displayed in an iframe. The page contains an input which has attached a datepicker. The height of the iframe is 170px and the height of the datepicker div is 154 px so it could actually fit in the available space but it is displayed somewhere to the top of the iframe with the header part cut off. (The _checkOffset method returns -31)

Attachments (1)

example.html (159 bytes) - added by endorielle 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by kbwood

I can't replicate this situation. Can you post the code for your page?

Changed 10 years ago by endorielle

Attachment: example.html added

comment:2 Changed 10 years ago by endorielle

I've uploaded a basic example. The bug reproduces with the provided file on both Firefox 3 and IE 8.

comment:3 Changed 10 years ago by kbwood

Resolution: fixed
Status: newclosed

Fixed in r2958. Ensured that the position has a minimum value of 0,0.

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

comment:18 Changed 7 years ago by mikesherov

#4848 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.