Opened 10 years ago

Closed 7 years ago

#4701 closed bug (duplicate)

Resizable: Issue resizing with a scrollable containment: 'parent'

Reported by: oggy Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.resizable Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

This is a variant of #3074. The workaround presented there doesn't work when the string "parent" is passed as the containment option. I've attached a fix, though it could probably be improved since the containerElement is already calculated elsewhere in the code.

Attachments (1)

resizable_3074.patch (680 bytes) - added by oggy 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by oggy

Attachment: resizable_3074.patch added

comment:1 Changed 10 years ago by Scott González

Component: ui.coreui.resizable
Milestone: TBD1.8

comment:2 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:3 Changed 7 years ago by tj.vantoll

Status: newopen
Summary: Resizable jumps when in scrolled container.Resizable: Issue resizing with a scrollable containment: 'parent'

This is still an issue in 1.9.1 - http://jsfiddle.net/tj_vantoll/YwMXS/.

comment:4 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: openclosed

Duplicate of #3815.
This was actually fixed by https://github.com/jquery/jquery-ui/commit/a1b32b59d57c2171af9ba0ed6b35ccde28794e3b for #3815. The test case works fine with updated version numbers: http://jsfiddle.net/tj_vantoll/YwMXS/4/.

Note: See TracTickets for help on using tickets.