Opened 10 years ago

Closed 7 years ago

Last modified 6 years ago

#3815 closed bug (fixed)

Resizable: absolutely positioned element inside scrollable element is repositioned when resized

Reported by: robmonie Owned by:
Priority: major Milestone: 1.10.0
Component: ui.resizable Version: 1.6rc4
Keywords: haspatch position Cc:
Blocked by: Blocking:

Description

Scenario:

A scrollable container that is scrolled by some number of pixels contains an absolutely positioned element (relative to the scrollable) that is resizable.

Problem:

On resizing of the resizable element, it is moved vertically up by the same number of pixels that the scrollable container is scrolled.

The attached test case has further details

Attachments (1)

jquery-ui-1.6-tests.zip (169.3 KB) - added by robmonie 10 years ago.
Test Case

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by robmonie

Attachment: jquery-ui-1.6-tests.zip added

Test Case

comment:1 Changed 10 years ago by Scott González

Milestone: TBD1.6

comment:2 Changed 10 years ago by rdworth

Milestone: 1.71.8

comment:3 Changed 8 years ago by Corey Frang

Any chance someone can fiddle up a non-working version of this one? I haven't had any luck, it seems to work correctly every time for me...

comment:4 Changed 8 years ago by k_borchers

Here is a fiddle of it not working based on the example provided in the zip attachment. Scroll the div down, then resize the resizable and it will jump up the same amount as you scrolled. http://jsfiddle.net/x83Pa/4/

comment:5 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:7 Changed 7 years ago by tj.vantoll

#3635 is a duplicate of this ticket.

comment:8 Changed 7 years ago by tj.vantoll

Keywords: haspatch added; resizable removed
Status: newopen
Summary: Resizable absolutely positioned element inside scrollable element is repositioned when resizedResizable: absolutely positioned element inside scrollable element is repositioned when resized

Another test case from closed duplicate issue http://jsfiddle.net/tj_vantoll/wLrwt/.

comment:9 Changed 7 years ago by Mike Sherov

Resolution: fixed
Status: openclosed

Resizable: use css() instead of position() for absolute placement. Fixes #3815 - Resizable: absolutely positioned element inside scrollable element is repositioned when resized

Changeset: a1b32b59d57c2171af9ba0ed6b35ccde28794e3b

comment:10 Changed 7 years ago by mikesherov

Milestone: 2.0.01.10.0

comment:11 Changed 6 years ago by tj.vantoll

#4701 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.