Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#4814 closed bug (wontfix)

'Today' doesn't show properly in button panel

Reported by: tommyhp2 Owned by:
Priority: minor Milestone:
Component: ui.datepicker Version: 1.7.2
Keywords: date picker button panel Cc:
Blocked by: Blocking:

Description

Hi,

When I have these settings on, the 'Today' doesn't show properly in the button panel. It shows as 'T24028a09' which seems like T + today's dd/mm/yy garbled in.

Here are my settings: $("#datepicker").datepicker( {

buttonImage : 'resources/images/jquery/calendar.gif', buttonImageOnly : true, buttonText : 'Choose', changeMonth : true, changeYear : true, closeText : 'Done', constrainInput : true, currentText : 'Today', dateFormat : 'mm/dd/yy', defaultDate : '+2', duration : 'fast', firstDay : 1, gotoCurrent : false, hidelfNoPrevNext : false, isRTL : false, maxDate : '+2m', minDate : '-1', navigationAsDateFormat : true, nextText : 'Next', numberOfMonths : 1, prevText : 'Prev', shortYearCutoff : '+10', showAnim : 'show', showButtonPanel : true, showCurrentAtPos : 0, showMonthAfterYear : false, showOn : 'both', showOptions: {direction: 'up' }, stepMonths : 1, yearRange : '-10:+10'

});

Thanks, Tommy

Attachments (1)

jquery_bug_submit.html (10.5 KB) - added by tommyhp2 11 years ago.
Bugs in jQuery UI DatePicker

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by kbwood

Resolution: wontfix
Status: newclosed

The navigationAsDateFormat setting applies to the previous, next, and today links. To retain the value of 'Today' you need to quote the value so that it doesn't get parsed and replaced:

currentText: '\'Today\

comment:2 Changed 11 years ago by kbwood

There should be two extra single quotes at the end of the previous example - Wiki formatting dropped them!

Changed 11 years ago by tommyhp2

Attachment: jquery_bug_submit.html added

Bugs in jQuery UI DatePicker

comment:3 in reply to:  1 Changed 11 years ago by tommyhp2

Replying to kbwood:

The navigationAsDateFormat setting applies to the previous, next, and today links. To retain the value of 'Today' you need to quote the value so that it doesn't get parsed and replaced:

currentText: '\'Today\

I've commented out the currentText to use the script's default. The problem persists. Please see attachment for problem. The attachment is a sample of a layout that I intend to use in some of my pages.

Thanks, Tommy

comment:4 Changed 8 years ago by nn_kirke

With the next configuration the today button don't have problem

Datepicker $('#datepicker').datepicker({

showButtonPanel: true,

});

But if you add other parameter like "navigationAsDateFormat"

Datepicker $('#datepicker').datepicker({

showButtonPanel: true,

navigationAsDateFormat: true,

});

The the text buttom show a number not a text.

comment:5 Changed 8 years ago by Scott González

#8236 is a duplicate of this ticket.

comment:6 Changed 8 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.