Opened 10 years ago

Closed 9 years ago

Last modified 7 years ago

#4843 closed enhancement (duplicate)

Add support for Thai year format in datepicker module

Reported by: panuta Owned by:
Priority: minor Milestone: 1.8
Component: ui.datepicker Version: 1.7.2
Keywords: thai year Cc:
Blocked by: Blocking:

Description

Year number that is used in Thailand is 543 ahead of western year number.

For example, says this year is 2009 in western format, in Thailand it will be 2552, which was mathematically calculated by adding 543 to 2009.

Normal localization method is not capable of doing this. I suggest to add an option in datepicker specifying how many years to be added to normal year number, for displaying purpose only.

Change History (4)

comment:1 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.next

So when asking the datepicker for the year, you still want to get the Western-based year back?

comment:2 Changed 10 years ago by panuta

Yes, it should return western-based year back. Both set and get action should require using Gregorian year as usual. Supporting Thai year will affect only when displaying the calendar to user.

YUI Calendar does support this feature by setting YEAR_OFFSET option to specify an offset value from Gregorian year. They have an example using this option for Taiwan calendar http://developer.yahoo.com/yui/examples/calendar/taiwan.html

So this option does not only benefit to Thai localization, but Taiwan as well.

comment:3 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5789.

comment:4 Changed 7 years ago by Scott González

Milestone: 1.next1.8
Note: See TracTickets for help on using tickets.