Opened 11 years ago

Closed 11 years ago

#4845 closed bug (duplicate)

sortable behaves differently with links when using connectWith

Reported by: jjinux Owned by:
Priority: minor Milestone: 1.8
Component: ui.sortable Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

If you have a ul list of links, and you make them sortable, then dragging the links doesn't actually click on the links. However, if you connect two ul lists of links, and you drag from one list to another, the link actually gets clicked.

Sorry I don't have a simple repro file. Hopefully it's not too hard for you to make one.

Change History (3)

comment:1 Changed 11 years ago by jjinux

Oh, and it's not always consistent. It's a race condition whether the link will be followed or not.

The most interesting and misleading thing is that if you do an Ajax call in the update callback, and the browser decides to follow the link that you clicked on in order to drag-and-drop it, the Ajax request will be canceled and report failure.

comment:2 Changed 11 years ago by Jörn Zaefferer

Milestone: TBD1.8

comment:3 Changed 11 years ago by Jörn Zaefferer

Resolution: duplicate
Status: newclosed

Actually, a duplicate of #4752.

Note: See TracTickets for help on using tickets.