Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#5074 closed bug (duplicate)

widget ui.tabs not working with jQuery 1.4

Reported by: thomtomdup Owned by:
Priority: major Milestone:
Component: ui.tabs Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

The widget ui.tabs does not work with jQuery 1.4. It adds:

<a href="#ui-tabs-[object%20Object]">

then it should be this example:

<a href="#ui-tabs-22">

Change History (4)

comment:1 Changed 10 years ago by pv-jaldert

This is because jQuery 1.4 changed the jQuery.data(elem) function. It no longer returns an id, but an object. _tabId therefore returns the object instead of an id. This also occurs in the _cookie function.

comment:2 in reply to:  1 Changed 10 years ago by pv-jaldert

#5065 has a workaround

Replying to pv-jaldert:

This is because jQuery 1.4 changed the jQuery.data(elem) function. It no longer returns an id, but an object. _tabId therefore returns the object instead of an id. This also occurs in the _cookie function.

comment:3 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5065.

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.