Opened 10 years ago

Closed 7 years ago

#5177 closed bug (notabug)

IE8 overlay display error.

Reported by: mikebird Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.dialog Version: 1.8rc1
Keywords: overlay Cc:
Blocked by: Blocking:

Description

When a modal dialog is displayed in IE8 and the height of the ui-widget-overlay div exceeds 32768 (32k), the filter:Alpha(Opacity=50) has no impact, either the background is solid or not shown at all.

Change History (10)

comment:1 Changed 10 years ago by Scott González

Milestone: TBD1.later
Priority: majortrivial

comment:2 Changed 10 years ago by mikebird

A workaround is adding a max-height setting to the .ui-widget-overlay css class.

Another issue here is the performance on IE, the dialog appears only after the overlay is rendered making dialogs very slow on medium to large documents.

comment:3 Changed 8 years ago by Scott González

Keywords: overlay added

comment:4 Changed 8 years ago by Scott González

#7974 is a duplicate of this ticket.

comment:5 Changed 8 years ago by jdavis78

7974 isn't an exact dupe, in the test case I posted, the height is around 5K, substantially less than the 32K in this ticket. And setting max-height on .ui-widget-overlay didn't change/correct the behavior. Also, the performance seems fine, not seeing an issue there. Any other thoughts or work arounds to try?

comment:6 Changed 8 years ago by Scott González

Milestone: 1.later1.9

comment:7 Changed 7 years ago by deulis

I spent all day searching for a solution to this problem and found nothing. Finally I made my own “work around”. I made a single png image called “ui-bg.png” with 50% of transparency. Then I replaced my current

.ui-widget-overlay { background: #666666; opacity: .50; filter:Alpha(Opacity=50); }

by

.ui-widget-overlay { background: url(images/ui-bg.png) repeat;}

It work on FireFox and Chrome too. This is a simple solution but it involves an image.

Hope this helps.

comment:8 Changed 7 years ago by Scott González

Priority: trivialminor

comment:9 Changed 7 years ago by Scott González

Milestone: 1.9.01.10.0

comment:10 Changed 7 years ago by davenaeder

Resolution: invalid
Status: newclosed

Re created the issue described here: http://jsfiddle.net/davenaeder/3hvSx/2/

Unable to reproduce the mentioned outcome.

Note: See TracTickets for help on using tickets.