Opened 10 years ago

Closed 9 years ago

#5265 closed bug (fixed)

Button: When opening dialog button keeps focus

Reported by: Rwhitbeck Owned by:
Priority: major Milestone: 1.9.0
Component: ui.button Version: 1.8rc3
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Rwhitbeck)

A clicked button has keyboard focus (ui-state-focus) Button doesn't blur when dialog is opened.

forum: http://forum.jquery.com/topic/new-button-issue

Demo of issue: http://jsbin.com/ehubo

Change History (10)

comment:1 Changed 10 years ago by Jörn Zaefferer

Component: ui.dialogui.button
Description: modified (diff)
Milestone: TBD1.next
Priority: trivialmajor
Summary: Button holds hover class when opening a dialogButton: hover and focus state look the same
Type: bugenhancement

comment:2 Changed 10 years ago by Rwhitbeck

Description: modified (diff)
Summary: Button: hover and focus state look the sameButton: When opening dialog button keeps focus

comment:3 Changed 10 years ago by deckberg

Looks like this is still a problem in Firefox 3.6.4 beta

comment:4 Changed 9 years ago by deckberg

Looks like this is still an issue with FireFox 3.6.11 with jQuery 1.4.3 and jQuery UI 1.8.5

comment:5 Changed 9 years ago by danbhfive

confirmed with chromium 12.0.703.0 with jQuery 1.5.1 and jQuery UI 1.8.11

comment:6 Changed 9 years ago by ajpiano

Status: newopen

comment:7 Changed 9 years ago by Scott González

Type: enhancementbug

comment:8 Changed 9 years ago by bruce511

comment:9 Changed 9 years ago by bruce511

comment:10 Changed 9 years ago by Scott González

Milestone: 1.next1.9
Resolution: fixed
Status: openclosed

This appears to be fixed in master.

Note: See TracTickets for help on using tickets.