Opened 9 years ago

Closed 7 years ago

#5335 closed bug (duplicate)

Resizable: position set to absolute at end of resize

Reported by: Rwhitbeck Owned by:
Priority: major Milestone: 2.0.0
Component: ui.resizable Version: 1.8rc3
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by rdworth)

Resizable sets element to position: absolute at the end of resize.

See forum for more details: https://forum.jquery.com/topic/problem-with-draggable-and-resizable

Change History (12)

comment:1 Changed 9 years ago by rdworth

Description: modified (diff)

comment:2 Changed 9 years ago by rdworth

Summary: Problem with draggable and resizableResizable: position set to absolute at end of resize

comment:3 Changed 9 years ago by rdworth

May be related to #3815

comment:4 Changed 9 years ago by AzaToth

The issue here is not cause of resizable, but the causing plugin is draggable, test added to http://github.com/azatoth/jquery-ui/commit/40175b06bdf282f9121b63b764384b5b105a1af6 which confirm this.

comment:5 Changed 9 years ago by AzaToth

Perhaps this bug should be moved to draggable.

comment:6 Changed 9 years ago by rdworth

The issue seems related to both resizable and draggable since you need an element that's both for the issue to present. Since the issue presents on resize, not drag, seems fitting to leave it as a resizable ticket, regardless of where the final fix may be implemented (which is not yet clear from the test).

comment:7 Changed 9 years ago by mco

It's definitely not the fix, but in my case setting html element css-position to absolute just after making it draggable and resizable fixes this issue.

My case is (shorthand notation, hope it's clear):

  • div { position: absolute, top: 100px, left,right,bottom: 0px, overflow: scroll} containing:
    • div { position: relative, width,height set by javascript dynamically} (just to set the containing block for absolutely-positioned elements) containing:
      • img { position: absolute, w,h: 100% }
      • div { position absolute, w,h: 100%; z-index: 1 } containing:
        • a few divs, that are subject to the issue (jqueryui draggable, resizeable)

I read somewhere that scrolling is probably one of the sources of this behaviour. In my scenario it happens no matter if content fits the scrollable container (scrollbars disabled) or not (scrollbars enabled).

comment:8 Changed 9 years ago by Scott González

Priority: criticalmajor

comment:9 Changed 8 years ago by codeblock

Another vote for this...

comment:10 Changed 7 years ago by dennyphilip

The resizable seems to set its containment to the the elements draggable ui-wrapper.

Last edited 7 years ago by dennyphilip (previous) (diff)

comment:11 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:12 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #6939.

Note: See TracTickets for help on using tickets.