Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#5394 closed bug (notabug)

Tests: Reproduce ticket-specific visual tests in unit tests where possible

Reported by: Jörn Zaefferer Owned by:
Priority: major Milestone: 1.9.0
Component: [meta] ui.test Version: 1.8
Keywords: Cc:
Blocked by: Blocking:

Description

Put them in [plugin]_tickets.js.

Change History (2)

comment:1 Changed 8 years ago by Jörn Zaefferer

Resolution: invalid
Status: newclosed

Should track that individually, if at all. Ticket specific tests are silly anyway.

comment:2 Changed 8 years ago by Scott González

We generally track suite-wide changes in single tickets, especially when they don't result in any API changes.

For this specific issue, the general idea is still valid, though the suggestion is not. We shouldn't have ticket-specific tests, but we should make sure that we're moving visual tests to unit tests as much as possible.

It's also not good to close a generic ticket in favor of specific tickets without the specific tickets already existing, since the reminder (ticket) is now off of our radar. In this case, we've got the visual test page cleanup wiki page and it's on the roadmap, so I'm fine with the ticket being closed (though I don't think it's invalid).

Note: See TracTickets for help on using tickets.