Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#5445 closed bug (fixed)

ThemeRoller is not building themes consistently

Reported by: ajpiano Owned by: jdsharp
Priority: blocker Milestone: 1.8.3
Component: [meta] ui.downloadbuilder Version: 1.8
Keywords: Cc:
Blocked by: Blocking:

Description

A number of users have reported getting themes that do not reflect the choices they made in TR. TR appears to be regularly bouncing out themes that do not include a CSS folder.

Here are two theme URLs that display correctly when loaded, but have been producing inconsistent results.

http://jqueryui.com/themeroller/?themeParams=%3FffDefault%3DHelvetica%252C+Arial%252C+sans-serif%26fwDefault%3Dbold%26fsDefault%3D1.1em%26cornerRadius%3D4px%26bgColorHeader%3Ddddddd%26bgTextureHeader%3D03_highlight_soft.png%26bgImgOpacityHeader%3D50%26borderColorHeader%3Ddddddd%26fcHeader%3D444444%26iconColorHeader%3D2d4d80%26bgColorContent%3Dffffff%26bgTextureContent%3D01_flat.png%26bgImgOpacityContent%3D75%26borderColorContent%3Ddddddd%26fcContent%3D444444%26iconColorContent%3Dff0084%26bgColorDefault%3Df6f6f6%26bgTextureDefault%3D03_highlight_soft.png%26bgImgOpacityDefault%3D100%26borderColorDefault%3Ddddddd%26fcDefault%3D172643%26iconColorDefault%3D666666%26bgColorHover%3D2d4d80%26bgTextureHover%3D12_gloss_wave.png%26bgImgOpacityHover%3D25%26borderColorHover%3D172643%26fcHover%3Dffffff%26iconColorHover%3Dffffff%26bgColorActive%3Dffffff%26bgTextureActive%3D02_glass.png%26bgImgOpacityActive%3D65%26borderColorActive%3Ddddddd%26fcActive%3D7d2a86%26iconColorActive%3D454545%26bgColorHighlight%3Dfeefc8%26bgTextureHighlight%3D01_flat.png%26bgImgOpacityHighlight%3D55%26borderColorHighlight%3Dcb7c01%26fcHighlight%3D444444%26iconColorHighlight%3D172643%26bgColorError%3Dffd1d1%26bgTextureError%3D01_flat.png%26bgImgOpacityError%3D55%26borderColorError%3Dff0300%26fcError%3D222222%26iconColorError%3Dff000f%26bgColorOverlay%3Deeeeee%26bgTextureOverlay%3D01_flat.png%26bgImgOpacityOverlay%3D0%26opacityOverlay%3D80%26bgColorShadow%3Daaaaaa%26bgTextureShadow%3D01_flat.png%26bgImgOpacityShadow%3D0%26opacityShadow%3D60%26thicknessShadow%3D4px%26offsetTopShadow%3D-4px%26offsetLeftShadow%3D-4px%26cornerRadiusShadow%3D0px

http://jqueryui.com/themeroller/#ffDefault=Verdana%2CArial%2Csans-serif&fwDefault=normal&fsDefault=1.1em&cornerRadius=4px&bgColorHeader=0081E3&bgTextureHeader=03_highlight_soft.png&bgImgOpacityHeader=75&borderColorHeader=aaaaaa&fcHeader=222222&iconColorHeader=222222&bgColorContent=0081E3&bgTextureContent=01_flat.png&bgImgOpacityContent=75&borderColorContent=0081E3&fcContent=222222&iconColorContent=222222&bgColorDefault=0081E3&bgTextureDefault=02_glass.png&bgImgOpacityDefault=75&borderColorDefault=d3d3d3&fcDefault=555555&iconColorDefault=888888&bgColorHover=0081E3&bgTextureHover=02_glass.png&bgImgOpacityHover=75&borderColorHover=999999&fcHover=212121&iconColorHover=454545&bgColorActive=0081E3&bgTextureActive=02_glass.png&bgImgOpacityActive=65&borderColorActive=aaaaaa&fcActive=212121&iconColorActive=454545&bgColorHighlight=0081E3&bgTextureHighlight=02_glass.png&bgImgOpacityHighlight=55&borderColorHighlight=0081E3&fcHighlight=0081E3&iconColorHighlight=2e83ff&bgColorError=fef1ec&bgTextureError=05_inset_soft.png&bgImgOpacityError=95&borderColorError=cd0a0a&fcError=cd0a0a&iconColorError=cd0a0a&bgColorOverlay=0081E3&bgTextureOverlay=01_flat.png&bgImgOpacityOverlay=0&opacityOverlay=30&bgColorShadow=aaaaaa&bgTextureShadow=01_flat.png&bgImgOpacityShadow=0&opacityShadow=30&thicknessShadow=8px&offsetTopShadow=-8px&offsetLeftShadow=-8px&cornerRadiusShadow=8px

Change History (8)

comment:1 Changed 10 years ago by ajpiano

Summary: ThemeRoller is not bulding themes consistentlyThemeRoller is not building themes consistently

comment:2 Changed 10 years ago by ajpiano

comment:3 Changed 10 years ago by Scott González

Milestone: TBD1.9

comment:4 Changed 10 years ago by rdworth

Component: [meta] ui.themeroller[meta] ui.downloadbuilder
Resolution: duplicate
Status: newclosed

Duplicate of #5414

comment:5 Changed 10 years ago by rdworth

Priority: criticalblocker
Resolution: duplicate
Status: closedreopened

may not be a duplicate after all, should be investigated separately

comment:6 Changed 10 years ago by jdsharp

I've done additional research and isolated the problem to 2 of the 4 load balancer servers and updated the cluster with the two servers that work. Please verify.

comment:7 Changed 10 years ago by jdsharp

Resolution: fixed
Status: reopenedclosed

comment:8 Changed 9 years ago by Scott González

Milestone: 1.91.8.3
Note: See TracTickets for help on using tickets.