Opened 10 years ago

Closed 8 years ago

#5465 closed bug (worksforme)

Quickly switching ajax tabs results in empty page with cache enabled

Reported by: scr4ve Owned by:
Priority: major Milestone: 1.9.0
Component: ui.tabs Version: 1.8
Keywords: cache Cc:
Blocked by: Blocking:

Description

Having several Ajax Tabs with caching enabled: Switching to another tab while the current active tab is still loading kills the previously active tab: If I switch back, I get an empty page. Disabling the cache option solves the problem. Problem applies to Firefox 3.6.2 and Chrome 4.1.249.1042

Change History (6)

comment:1 Changed 10 years ago by scr4ve

Workaround:

function fixTabAbort(event,ui){
	jQuery(ui.tab).data("cache.tabs",(jQuery(ui.panel).html() == "") ? false : true);
}

jQuery("#id").tabs(
	{
		cache: true,
		load: fixTabAbort
	});

comment:2 Changed 10 years ago by pdebruic

The function above wasn't working for me for some reason, but this did:

(function($){
       $.fn.fixTabAbort=function(){
                $('.ui-tabs-selected a:first').data("cache.tabs",($('.ui-tabs-panel:visible').html() == "") ? false : true);
        };
})(jQuery);

comment:3 Changed 9 years ago by Scott González

Priority: criticalmajor

comment:4 Changed 8 years ago by carson

I wasn't able to reproduce this issue: http://jsfiddle.net/vdf7N/

In the above link click the "Tab 1" tab then immediately click the "Tab 2" tab. Wait for "Tab 2" tab to get its data then go back to "Tab 1" and you should see an error message but after 3 seconds that error message will be replaced by the correct text as it should be.

Last edited 8 years ago by carson (previous) (diff)

comment:5 Changed 8 years ago by Scott González

#5366 is a duplicate of this ticket.

comment:6 Changed 8 years ago by Scott González

Resolution: worksforme
Status: newclosed

I can't reproduce this either, using carson's test page, even going back to 1.8.

Note: See TracTickets for help on using tickets.