Opened 10 years ago

Closed 9 years ago

Last modified 7 years ago

#5595 closed bug (notabug)

jQuery('a').button().click() causes click event to be fired twice

Reported by: metalculus84 Owned by: metalculus84
Priority: major Milestone:
Component: ui.button Version: 1.8.1
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery('a').button().click() causes click event to be fired twice jQuery('a').click().button() works as expected.

It shouldn't matter what order these calls are made in the chain right?

Change History (4)

comment:1 Changed 9 years ago by danbhfive

Owner: set to metalculus84
Status: newpending

I tried to test this with jquery ui 1.8.1, and I couldn't get this behavior. Here is my test case: http://jsbin.com/axube5/5

Please provide a valid test case and reopen, thanks!

comment:2 Changed 9 years ago by fofanafi

Tested using jQuery('a').button().click() and jquery ui 1.8.1; also could not reproduce the behavior.

http://jsbin.com/ehubo/19

comment:3 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.