Opened 9 years ago

Closed 7 years ago

#5631 closed bug (duplicate)

Datepicker: Allows disabled input to trigger datepicker

Reported by: laurenty Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.datepicker Version: 1.8.1
Keywords: Cc:
Blocked by: Blocking:

Description

The Datepicker constructor should check the "disabled" property of its target input control and set its own disabled state accordingly.

When a webpage is rendered with the following markup:

<input type="text" name="date" id="mydate" disabled="disabled">

The Datepicker should also be rendered disabled when running the following code.

$("#mydate").datepicker({
	showOn: 'button',
	buttonImage: 'images/calendar.gif',
	buttonImageOnly: true
});

Change History (3)

comment:1 Changed 8 years ago by Emyr

This is a "feature": http://bugs.jqueryui.com/ticket/4079

It allows users to be forced to use the datepicker, against usability principles.

I believe allowing the editing of disabled inputs using the datepicker should be an option, defaulting to false.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD1.11.0

comment:3 Changed 7 years ago by petersendidit

Resolution: duplicate
Status: newclosed
Summary: Datepicker with disabled input controlsDatepicker: Allows disabled input to trigger datepicker

Duplicate of #4079.

Note: See TracTickets for help on using tickets.