Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#5645 closed feature (fixed)

Position: Allow for arbitrary element to be containing element

Reported by: AzaToth Owned by:
Priority: blocker Milestone: 1.9.0
Component: ui.position Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

At the moment, the collision is only defined in relation to window. I think that any arbitrary containing element, possible limited to parent elements, should be able to be used as the container which collisions are calculated from.

Change History (8)

comment:1 Changed 9 years ago by Jörn Zaefferer

Milestone: TBD1.next
Priority: minormajor
Type: enhancementfeature

This could be another option, called "within", with window as the default.

comment:2 Changed 8 years ago by Corey Frang

I just saw a pretty perfect use case for this while trying to help someone on #jQuery.

Lets say you have some wide content you want to position to the left/right of your hovered element, but you don't want this content to break outside of your current pages flow. If you could {within: '#contiainer', my: 'top left', at:'top right', collision:'flip'}

comment:3 Changed 8 years ago by Scott González

#6983 is a duplicate of this ticket.

comment:4 Changed 8 years ago by Scott González

Milestone: 1.next1.9
Priority: majorblocker
Status: newopen

comment:5 Changed 8 years ago by Scott González

Summary: position should allow for arbitary element to be containing elementPosition: Allow for arbitrary element to be containing element

comment:7 Changed 8 years ago by Jörn Zaefferer

Resolution: fixed
Status: openclosed

For some reason I never closed this ticket. Fixed by 433ed6eecf055eba327ced7e7c0ff0ce9b5fc304 / https://github.com/jquery/jquery-ui/pull/254

comment:8 Changed 7 years ago by Scott González

#8190 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.