Opened 9 years ago

Closed 7 years ago

#5657 closed bug (duplicate)

Draggable breaks in IE7 IE8

Reported by: YohanT Owned by:
Priority: major Milestone: 2.0.0
Component: ui.draggable Version: 1.8.1
Keywords: Cc:
Blocked by: Blocking:

Description

When i refresh a Tree on IE7/8 the dragged object never call the "stop" event and the clone object is leaved everywhere on the screen...

Adding "if( $(this).data('draggable') )" on this stop event solved this problem for me...

$.ui.plugin.add("draggable", "cursor", {

start: function(event, ui) {

var t = $('body'), o = $(this).data('draggable').options; if (t.css("cursor")) o._cursor = t.css("cursor"); t.css("cursor", o.cursor);

}, stop: function(event, ui) {

if( $(this).data('draggable') ) {

var o = $(this).data('draggable').options; if (o._cursor) $('body').css("cursor", o._cursor);

}

}

});

Change History (4)

comment:1 Changed 9 years ago by Scott González

Priority: blockermajor

comment:2 Changed 8 years ago by maljub01

If I understand this correctly, I believe that both this ticket and mine (http://bugs.jqueryui.com/ticket/7800) are caused by the same bug.

Can you please check if the fix I submitted with my ticket fixes this one too? Here's a link to it: https://github.com/maljub01/jquery-ui/commit/c3c84002898163c3c6625a4fedcddf1434f8e448

comment:3 Changed 7 years ago by Scott González

Milestone: TBD2.0.0

comment:4 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #7800.

Note: See TracTickets for help on using tickets.