Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#5666 closed bug (duplicate)

button remains in focused state when it opens a dialog

Reported by: klawd Owned by:
Priority: minor Milestone:
Component: ui.button Version: 1.8.2
Keywords: button, dialog Cc:
Blocked by: Blocking:

Description

a button that opens a dialog will stay in focused state until you click it again.

see http://jsfiddle.net/wjL3t/

or use this code, in case the fiddle gets deleted:

<button id="button1">test1</button>
<button id="button2">test2</button>
<button id="button3">test3</button>
<div id="dialog"></div>
<script>
$('#button1').button().click(function(){ $('#dialog').dialog(); });
$('#button2').button().click(function(){ $('#dialog').dialog(); });
$('#button3').button().click(function(){ $('#dialog').dialog(); });
</script>

Change History (3)

comment:1 in reply to:  description Changed 9 years ago by klawd

Replying to klawd:

a button that opens a dialog will stay in focused state until you click it again.

see http://jsfiddle.net/wjL3t/

or use this code, in case the fiddle gets deleted:

<button id="button1">test1</button>
<button id="button2">test2</button>
<button id="button3">test3</button>
<div id="dialog"></div>
<script>
$('#button1').button().click(function(){ $('#dialog').dialog(); });
$('#button2').button().click(function(){ $('#dialog').dialog(); });
$('#button3').button().click(function(){ $('#dialog').dialog(); });
</script>

Note that only the the button that actually initially opens the dialog shows this behaviour

comment:2 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5265.

comment:3 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.