Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#5700 closed bug (duplicate)

Jquery.ui.diaglog.js drag containment Bug

Reported by: 纯粹误会 Owned by:
Priority: minor Milestone:
Component: ui.dialog Version: 1.8.1
Keywords: Cc:
Blocked by: Blocking:

Description

Here it is:

I just found that there might have a Bug in the Jquery.ui.diaglog.js as we know there is a paramerter called "containment" between dragable & resizable.and it's default value is "document".it controls the draging always keeping in the document area. but when the target page is not an entire page. when it's an opened small page. and also included a dragable dialog..then it doesn't work I think..at least the range we can control is truning too small.

so here is my solution: add a paramerter called "options.containment"(for example)..the default value is "document".and the relevant containments of draggable & resizable also can be changed to "options.containment"...then we can control it easily.

Change History (2)

comment:1 Changed 10 years ago by rdworth

Resolution: duplicate
Status: newclosed

Duplicate of #5699

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.