Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#5721 closed bug (duplicate)

Needs appendTo to maintain Styling and Scrolling

Reported by: sidot3291 Owned by:
Priority: major Milestone:
Component: ui.datepicker Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

appendTo may not be the only solution, but it's the only one that coming to me at the moment. Basically, the appendTo should perform similar to the appendTo for jquery draggables. With the ability to define where the datepicker gets appended, we would be able to avoid two major bugs:

#1 deals with styling. Because datepicker gets appended directly to the body, it's unusually difficult to style the specific datepicker element. Because it is applied at the body level, it affects the styling of other UI elements unless those elements are maintained in a specific scope. With appendTo, we can keep datepicker in it's own scope.

#2 deals with scrolling. If the datepicker element appears within a scrollable div, the calendar will not remain attached to the input element. I imagine this is because the calendar is placed relative to the body rather than relative to the scrollable div it's placed within. With appendTo, datepicker could know what it should be placed relative to. (There was a lot of assumption here, so I may be off base)

Thanks

Change History (3)

comment:1 Changed 9 years ago by sidot3291

comment:2 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #4306.

comment:3 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.