Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5739 closed bug (fixed)

Download Builder Won't Download Custom Themes

Reported by: kingjeffrey Owned by:
Priority: blocker Milestone: 1.8.3
Component: [meta] ui.downloadbuilder Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

Download Builder appears to be broken again. It will not download custom themes. All the parameters are being passed to the download url, but the custom theme provided in the download is "smoothness".

The theme I am trying to generate:

http://jqueryui.com/download/?themeParams=%3FffDefault%3D%2522Helvetica+Neue%2522%252CHelvetica%252CArial%252CTahoma%252C%2522Trebuchet+MS%2522%252Csans-serif%26fwDefault%3Dnormal%26fsDefault%3D14px%26cornerRadius%3D4px%26bgColorHeader%3D666666%26bgTextureHeader%3D05_inset_soft.png%26bgImgOpacityHeader%3D25%26borderColorHeader%3D555555%26fcHeader%3Dffffff%26iconColorHeader%3Dcccccc%26bgColorContent%3Dffffff%26bgTextureContent%3D01_flat.png%26bgImgOpacityContent%3D75%26borderColorContent%3D555555%26fcContent%3D000000%26iconColorContent%3D555555%26bgColorDefault%3Dcccccc%26bgTextureDefault%3D05_inset_soft.png%26bgImgOpacityDefault%3D35%26borderColorDefault%3D888888%26fcDefault%3D444444%26iconColorDefault%3D666666%26bgColorHover%3Daaaaaa%26bgTextureHover%3D05_inset_soft.png%26bgImgOpacityHover%3D35%26borderColorHover%3D555555%26fcHover%3D333333%26iconColorHover%3D444444%26bgColorActive%3Dff3333%26bgTextureActive%3D05_inset_soft.png%26bgImgOpacityActive%3D25%26borderColorActive%3D555555%26fcActive%3Dffffff%26iconColorActive%3Dffffff%26bgColorHighlight%3Dffffdd%26bgTextureHighlight%3D02_glass.png%26bgImgOpacityHighlight%3D55%26borderColorHighlight%3Dcccc77%26fcHighlight%3D000000%26iconColorHighlight%3D2473f5%26bgColorError%3Dffcccc%26bgTextureError%3D05_inset_soft.png%26bgImgOpacityError%3D95%26borderColorError%3Dff3333%26fcError%3Dff2222%26iconColorError%3Dff3333%26bgColorOverlay%3D999999%26bgTextureOverlay%3D07_diagonals_medium.png%26bgImgOpacityOverlay%3D100%26opacityOverlay%3D25%26bgColorShadow%3D999999%26bgTextureShadow%3D01_flat.png%26bgImgOpacityShadow%3D25%26opacityShadow%3D25%26thicknessShadow%3D1px%26offsetTopShadow%3D1px%26offsetLeftShadow%3D1px%26cornerRadiusShadow%3D5px

Change History (5)

comment:1 Changed 11 years ago by rdworth

Milestone: TBD1.9
Priority: majorblocker

comment:2 Changed 11 years ago by Scott González

Resolution: fixed
Status: newclosed

That URL didn't work for me, but building a custom theme did. Please try building your theme again.

comment:3 Changed 11 years ago by Scott González

Milestone: 1.91.8.3

comment:4 Changed 11 years ago by kingjeffrey

I've verified the problem is with specifying a two-word font name (such as "Helvetica Neue". This breaks the theme, and is reproducible.

comment:5 Changed 11 years ago by Scott González

The problem you're describing is #4379.

Note: See TracTickets for help on using tickets.