Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#5778 closed bug (duplicate)

Button widget inconsistency in Firefox when triggering dialog box

Reported by: dwreck Owned by:
Priority: minor Milestone:
Component: ui.button Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

If you have a dialog box linked to a button widget in UI 1.8.2, the hover class does not get removed in Firefox. Note this example:

http://jsbin.com/ubaro3

If you click on Button 1, you have a dialog box open up. In Firefox, you will note that you can see that Button 1 doesn't lose focus in the background when the dialog opens up (IE and Chrome work as you would expect, where the button does indeed lose focus).

Click OK to make the dialog box disappear, and you will notice in Firefox that Button 1 still has focus, even if you click on the text input field or on Button 2. (Incidentally, clicking on Button 3, a button element, does make Button 1 lose focus).

Should an extra blur event be added to the button and/or dialog widget code to fix this?

Change History (2)

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5265.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.