Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5779 closed bug (fixed)

Themeroller - size inconsistency with button widgets and dialog box buttons

Reported by: dwreck Owned by:
Priority: minor Milestone: 1.8.3
Component: ui.dialog Version: 1.8.2
Keywords: css Cc:
Blocked by: Blocking:

Description

The Themeroller produces a style for the buttons in dialog boxes that are noticably bigger than other button widgets on your page, especially if your page's base font size is bigger than that on the Themeroller page. This is because of this line of CSS in the resulting style sheet:

.ui-dialog .ui-dialog-buttonpane button { float: right; margin: .5em .4em .5em 0; cursor: pointer; '''padding: .2em .6em .3em .6em;''' line-height: 1.4em; width:auto; overflow:visible; }

Is that padding attribute by design? Removing it from this line makes the button look more in line with other button widgets on the page, and I'm thinking it should be removed from the Themeroller's generated CSS output.

Change History (5)

comment:1 Changed 6 years ago by dwreck

Sorry, the bolding didn't work in the code block. Here's the actual CSS code again, minus the extra apostrophees:

.ui-dialog .ui-dialog-buttonpane button { float: right; margin: .5em .4em .5em 0; cursor: pointer; padding: .2em .6em .3em .6em; line-height: 1.4em; width:auto; overflow:visible; }

comment:2 Changed 6 years ago by dwreck

One last thing - this issue is visible on the main Themeroller page. If you click on the sample dialog button, you can move the dialog box in such a way to line up its Cancel and Ok buttons with the "A button element" button to see the size difference.

comment:3 Changed 6 years ago by scottgonzalez

  • Component changed from [meta] ui.themeroller to ui.dialog
  • Milestone changed from TBD to 1.9
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 60dc674.

comment:4 Changed 6 years ago by scottgonzalez

  • Milestone changed from 1.9 to 1.8.3

comment:5 Changed 6 years ago by Scott González

Dialog: Removed CSS rules for button styling - let the button plugin handling that. Fixes #5779 - Themeroller - size inconsistency with button widgets and dialog box buttons.

Changeset: 60dc67400e5e55539d56cc066986f509c46a3c07

Note: See TracTickets for help on using tickets.