Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#6011 closed bug (duplicate)

ui.position calculation broken in all IE and webkit browsers

Reported by: mmahoney Owned by:
Priority: critical Milestone:
Component: ui.position Version: 1.8.4
Keywords: Cc:
Blocked by: Blocking:

Description

The ui.position feature does not work at all in anything but Firefox(version 3.6 was used in testing.). These were on a Windows XP machine.

A simple test case is attached with three divs, which attempts to place the third div absolutely positioned to the left and bottom of the second div.

In Chrome 5, position will be top: 0px and left: 0px

In IE 7 and 8, position will be top: 0px and left: 0px

Did not test IE 6, but I assume it is also incorrect.

For more fun, try setting a width, particularly a percentage. Again, Firefox works as expected, but Chrome and IE produce wildly incorrect values.

This behavior is consistently reproducible. I've done several other test cases, with height, width, and content differences. Firefox, OK. Others, broken.

Attachments (1)

test.html (1.2 KB) - added by mmahoney 9 years ago.
HTML file with simple test case

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by mmahoney

Attachment: test.html added

HTML file with simple test case

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5533.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.