Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#6044 closed bug (duplicate)

position breaks in chrome

Reported by: jogep Owned by:
Priority: major Milestone: 1.9.0
Component: ui.position Version: 1.8.5
Keywords: position chrome Cc:
Blocked by: Blocking:

Description

i try to refactor the ui.spinner. for this i want to use the position function to place the spinner buttons at the right side of the input element.

 wrapper.position({
   of: this.element,
   my: 'left center',
   at: 'right center',
   offset: '0 0',
   collision: 'flip flip'
 });

This works fine with firefox and IE but in Chrome it breaks the buttons on a new line.

You can try it out with the example page.

http://github.com/jogep/jquery.ui.spinner

Change History (2)

comment:1 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

This is likely a duplicate of #5533. There's a bug in jQuery core that requires the top and left values to be set to something other than auto in order for .position() to work. This has already been fixed in core and will be released with 1.4.3.

comment:2 Changed 7 years ago by Scott González

Milestone: 1.next1.9.0
Note: See TracTickets for help on using tickets.