Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6055 closed bug (fixed)

Autocomplete: Selecting an item by pressing enter submits the form in Opera

Reported by: can3p Owned by:
Priority: major Milestone: 1.8.6
Component: ui.autocomplete Version: 1.8.4
Keywords: Cc:
Blocked by: Blocking:

Description

If I enter a text in input, select item from autocomplete list and press enter, form is submitted in opera. To prevent it additional keyPress event should be added

Change History (5)

comment:2 Changed 6 years ago by scottgonzalez

  • Milestone changed from TBD to 1.9
  • Priority changed from minor to major
  • Summary changed from keyDown event doesn't prevent form from submit to Autocomplete: Selecting an item by pressing enter submits the form in Opera

comment:3 Changed 6 years ago by scottgonzalez

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in c3b282f.

comment:4 Changed 6 years ago by scottgonzalez

  • Milestone changed from 1.9 to 1.8.6

comment:5 Changed 6 years ago by Dmitry Petrov

Autocomplete: Prevent keypress events caused by enter key when selecting an item. Fixes #6055 - Autocomplete: Selecting an item by pressing enter submits the form in Opera.

Changeset: c3b282fceb8b5161c013575bf01c652d6573d72e

Note: See TracTickets for help on using tickets.