Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#6068 closed bug (wontfix)

Accordion: IE9 B gives null references on paddingTop and paddingBottom

Reported by: jmiller Owned by:
Priority: major Milestone:
Component: ui.accordion Version: 1.8.4
Keywords: ie9 Cc:
Blocked by: Blocking:

Description

Given fxAttrs = ["height", "paddingTop", "paddingBottom"], (line 535) and an accordion that has been been clicked and is trying to expand...

var parts = ("" + $.css(options.toShow[0], prop)).match(/([\d+-.]+)(.*)$/); (line 548-ish) is setting parts to null for each of the paddingTop and paddingBottom attributes in IE9 (Beta 1 using IE9 Standards mode), which throws exceptions when setting showProps[prop] circa line 550 and again when accessing each of the showProps values circa line 572.

This can be sort-of worked around with a null-check on the setting of showProps[prop] circa line 550, like "if (parts == null) { showProps[prop] = { value: 0, unit: "px" }; } else ...". It doesn't quite look right, but it's mostly right and not throwing errors.

(The priority may be wrong if IE9 changes its behavior prior to release.)

Change History (4)

comment:1 Changed 9 years ago by Scott González

The problem is that IE9b is reporting an empty string for padding on hidden elements. Showing the element prior to calculating dimensions, then hiding immediately after works around the problem.

comment:2 Changed 9 years ago by Scott González

Resolution: wontfix
Status: newclosed

I've confirmed that this is fixed in IE9 (in dev) and the problem will not exist in IE 9 final.

comment:3 Changed 9 years ago by Scott González

#6919 is a duplicate of this ticket.

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.