Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#6098 closed bug (notabug)

Opening dialog causing input to lost focus

Reported by: lampacz Owned by:
Priority: major Milestone: 1.9.0
Component: ui.dialog Version: 1.8.5
Keywords: focus Cc:
Blocked by: Blocking:

Description

Having form with focused text element and calling .dialog() to display message about loading autocomplete cause input to lost focus (same result with modal true or false)

				$oDiv.dialog({
					title: oM.title,
					height: 70,
					modal: oM.modal,
					resizable: false,
					close: function(event, ui) {
						if ($ajax)
							$ajax.abort();
					}
				});

Change History (3)

comment:1 Changed 10 years ago by Scott González

Resolution: invalid
Status: newclosed

Dialogs have to gain focus for accessibility. The user's focus (both in the DOM and in their mind) is now on the dialog.

comment:2 Changed 10 years ago by lampacz

i don't need accessibility i need only display information message (no modal in mostly cases)

maybee some option which will cause not losing focus ? or using something else for displaying information message

comment:3 Changed 9 years ago by Scott González

#7934 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.