Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#6149 closed bug (duplicate)

Tabs Highlight issue (with screenshots from multiple pcs)

Reported by: shadwdrgn Owned by:
Priority: minor Milestone:
Component: ui.tabs Version: 1.8.5
Keywords: Cc:
Blocked by: Blocking:

Description

The hover style remains on a tab after changing tabs if an Input is focused on "show" in javascript. Example code follows:

show: function(event, ui) {

if (ui.panel.id == "tab2") {

$(ui.panel).find("#url").focus(); $('#tab2').removeClass('ui-state-hover');

}

EXACTLY how to replicate (DO NOT click anywhere but where this tells you: 1) Go to http://1dl.us/ in firefox in windows OR linux. 2) Click on the "Shorten URL" tab. 3) Click on the "Info" tab.

Here is a screenshot of the bug: http://1dl.us/128629796288187.png

In another screenshot (http://1dl.us/128629800895854.png ) notice the "Read EMail" AND "Shorten URL" tabs are BOTH highlighted. That is because my mouse is over "Read EMail" and the bug keeps "Shorten URL" highlighted.

Here's a screenshot from a friend of mine's PC: http://1dl.us/128629827488699.jpg

Change History (3)

comment:1 Changed 9 years ago by shadwdrgn

the removeclass ui-state-hover was my attempt at a workaround. it happens with AND without that.

comment:2 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #6148.

comment:3 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.