Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#6169 closed bug (duplicate)

.net controls inside a dialog

Reported by: rklose Owned by:
Priority: major Milestone:
Component: ui.dialog Version: 1.8.5
Keywords: Cc:
Blocked by: Blocking:

Description

1) In order to make .net controls work in a jquery UI dialog the dialogs need to attach to the form instead of the document.

This can be done with the follow modifications Change line 8816 in jquery-ui-1.8.5 to .appendTo((document.forms.item(0) != null) ? document.forms.item(0) : document.body)

Change line 9036 in jquery-ui-1.8.5 to uiDialog.appendTo((document.forms.item(0) != null) ? document.forms.item(0) : document.body);

That will allow .net control hosted in a dialog to function properly.

This however raises a new issue. Since the dialog is now in the form, it needs to not post back when you click its buttons. To fix this change line 9102 in jquery-ui-1.8.5 to var button = $('<button type="button"></button>', props)

This will create an issue with the some of the internal functions specifically rsingleTag.exec( selector ) on line 114 in jquery-1.4.2.js. The regular expression doesn't understand that a single tag could have attributes. It can be corrected by change line 51 in jquery-1.4.2.js to

rsingleTag = /<(\w+)(\s+\w+="?\w+"?)*\s*\/?>(?:<\/\1>)?$/,

Change History (2)

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5762.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.