Opened 9 years ago

Closed 7 years ago

#6214 closed bug (wontfix)

Text in select dropdowns inside tab area doesn't fit initially in IE 8/9

Reported by: RandomEngy Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.tabs Version: 1.8.5
Keywords: Cc:
Blocked by: Blocking:

Description

If you've got select dropdown elements (without fixed sizes) inside a tab in IE8, the dropdown will be too small for the text, until you change tabs or click on the dropdown.

This issue is most noticeable when the font-size is unaltered on the document. If you have a font-size on the body like .75em or 10px the problem is less severe, with only the last couple of characters getting cut off usually.

Attachments (1)

dropdown_render_bug.png (3.6 KB) - added by RandomEngy 9 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by RandomEngy

Attachment: dropdown_render_bug.png added

comment:1 Changed 8 years ago by Scott González

Milestone: TBD1.9
Status: newopen

comment:2 Changed 8 years ago by Scott González

As a workaround you can run $( "select" ).css( "zoom", 1 ).

comment:3 Changed 8 years ago by Scott González

Summary: Text in select dropdowns inside tab area doesn't fit initially in IE 8Text in select dropdowns inside tab area doesn't fit initially in IE 8/9

This is fixed in the IE 10 preview.

comment:4 Changed 7 years ago by Scott González

Related to #7582.

comment:5 in reply to:  3 Changed 7 years ago by Scott González

Replying to scott.gonzalez:

This is fixed in the IE 10 preview.

Specifically it's fixed in Platform Preview 4, 10.0.8103.0; it was still broken as of the Dev Preview 10.0.8102.0

comment:6 Changed 7 years ago by Scott González

Resolution: wontfix
Status: openclosed
Note: See TracTickets for help on using tickets.