Opened 9 years ago

Closed 8 years ago

#6222 closed bug (wontfix)

Position breaks under zoomed webkit

Reported by: vonf Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.position Version: 1.8.5
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Scott González)

When zoomed in Chrome, using .position() places the element in the wrong position. The position is also inconsistent when called multiple times.

Attachments (1)

jquery-ui-position-chrome.png (52.3 KB) - added by vonf 9 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by vonf

comment:1 Changed 9 years ago by vonf

Don't forget to zoom once in chrome to see the bad behavior.

comment:2 Changed 9 years ago by vonf

If I understand the situation correctly, this affects a bunch of other things, including e.g. combobox.

Pretty sure that this bug is what's killing slate's <div id="tap3">, which also breaks when zoomed in chrome.

comment:3 Changed 9 years ago by Scott González

Component: ui.coreui.position
Description: modified (diff)
Milestone: TBD1.9

comment:4 Changed 9 years ago by Scott González

Summary: Position breaks under zoomed chomePosition breaks under zoomed webkit

This is fixed in Chrome 8 (dev).

comment:5 Changed 9 years ago by Scott González

#6706 is a duplicate of this ticket.

comment:6 Changed 8 years ago by Scott González

Resolution: wontfix
Status: newclosed

Fixed in Safari 5 as well. That leaves Safari 4 as the only supported browser with this bug. Closing as wontfix since we can't really work around it and it's been fixed in webkit for a while.

Note: See TracTickets for help on using tickets.