Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#6251 closed enhancement (duplicate)

Slider operating difficulties for same values in range selection

Reported by: josef.sabl Owned by:
Priority: minor Milestone:
Component: ui.slider Version: 1.8.5
Keywords: usability Cc:
Blocked by: Blocking:

Description

In case both upper and lower value handles (for range selection) have same value, it becomes very difficult to operate slider. You have to pull left handle to the left, but there is no visual clue that you have to do that.

Observed possible solutions:

  1. Implement an option that would prohibit for the higher value to be same as lower value (this would be useful anyway, consider price range selection in e-shop. You are not interested in items that have value precisely something.)
  2. When both handles overlap, replace them with visually different object (that would look like handles stuck together). Its right side would work as right handle. Its left side would work as left handle.

We used slider in our project and we had quite many user complaints all resulting from confusion caused by this usability bug.

Thanks

Change History (3)

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #3736.

comment:2 Changed 7 years ago by sv3tli0

Last edited 7 years ago by sv3tli0 (previous) (diff)

comment:3 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.