Opened 8 years ago

Closed 7 years ago

#6254 closed bug (duplicate)

Slider handles overlap datepicker popup

Reported by: manfer Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.datepicker Version: 1.8.5
Keywords: Cc:
Blocked by: Blocking:

Description

When placing a datepicker in popup mode above sliders, the slider handles appear in front of the popup.

I have tried the solution http://dev.jqueryui.com/ticket/4456 but it does not work. Though I set the css:

.ui-datepicker { z-index:100; }

as soon as the datepicker pop-ups it is given again a z-index=1.

Change History (4)

comment:1 Changed 7 years ago by Scott González

Milestone: TBD1.11.0

comment:2 Changed 7 years ago by mikesherov

Status: newopen

confirmed. This is due to: https://github.com/jquery/jquery-ui/blob/5bd5ef15f9f7d1820334abd52aa5ee4b25c992ba/ui/jquery.ui.datepicker.js#L693 which manually sets the zIndex of the datepicker div to 1 greater than the input it's spawned off of. If zIndex is already set by CSS, perhaps it should respect that instead?

comment:3 Changed 7 years ago by mikesherov

#7696 is a duplicate of this ticket.

comment:4 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: openclosed

Duplicate of #5479.

Note: See TracTickets for help on using tickets.