Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6786 closed bug (duplicate)

ui:tabs breaks when tab links contain dot

Reported by: fsologuren Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.tabs Version: 1.8.7
Keywords: Cc:
Blocked by: Blocking:

Description

Same problem that #2715, but developer only fixed problems with ':', not with '.'. Period also needs to be escaped in CSS selectors.

Preview: http://jsfiddle.net/qhSgY/2/

Suggestion:

        _sanitizeSelector: function( hash ) {
                // we need this because an id may contain a ":"
-               return hash.replace( /:/g, "\\:" );
+               return hash.replace( /:/g, "\\:" ).replace( /\./g, "\\\." );
        },
 
        _cookie: function() {

Change History (3)

comment:1 Changed 9 years ago by fsologuren

comment:2 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:3 Changed 9 years ago by Scott González

Duplicate of #4681.

Note: See TracTickets for help on using tickets.