Opened 10 years ago

Closed 8 years ago

#4681 closed bug (fixed)

Tabs: _sanitizeSelector needs to escape '.'

Reported by: liangent Owned by:
Priority: major Milestone: 1.9.0
Component: ui.tabs Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

45	        _sanitizeSelector: function(hash) {
46	                return hash.replace(/:/g, '\\:'); // we need this because an id may contain a ":"
47	        },

return hash.replace(/:/g, '\\:'); should be changed into something like return hash.replace(/([:\.])/g, '\\$1');. because dots can also cause problems.

Change History (6)

comment:1 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.8

comment:2 Changed 9 years ago by Scott González

#6786 is a duplicate of this ticket.

comment:3 Changed 9 years ago by fofanafi

Status: newopen

Verified for jQuery UI 1.8.11. See duplicate bug for test case in jsFiddle and fix.

comment:4 Changed 8 years ago by tomgallacher

comment:5 Changed 8 years ago by Scott González

Summary: _sanitizeSelector needs to escape '.'Tabs: _sanitizeSelector needs to escape '.'

comment:6 Changed 8 years ago by Scott González

Resolution: fixed
Status: openclosed

Tabs: Escape all special characters when sanitizing hash selectors. Fixes #4681 - Tabs: _sanitizeSelector needs to escape '.'.

Changeset: 5f10fa6511ae1965088926217776692a3f5663cb

Note: See TracTickets for help on using tickets.