Opened 9 years ago

Closed 7 years ago

#6792 closed feature (duplicate)

Dialog title bar (.ui-dialog .ui-dialog-titlebar) typesetting inconsistent with other widgets

Reported by: AaronP Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.dialog Version: 1.8.7
Keywords: Cc:
Blocked by: Blocking:

Description

The dialog titlebar type seems to be set too low. An even .4em on top and bottom still achieves a total padding height of .8em but sets the type correctly and more consistently with other widgets (note typesetting on accordion header, for example). I can't find mention of this on the forum or in past tickets. Current css uses this padding on the div:

.ui-dialog .ui-dialog-titlebar {
    padding: 0.5em 1em 0.3em;
    position: relative;
}

and this margin on the child span:

.ui-dialog .ui-dialog-title {
   margin: 0.1em 16px 0.2em 0;
}

Sent pull request on github.

Change History (5)

comment:1 Changed 9 years ago by RobLoach

In a related note, there's an extra whitespace at the end of .ui-dialog-title:

.ui-dialog .ui-dialog-titlebar { padding: .4em 1em; position: relative;  }
.ui-dialog .ui-dialog-title { float: left; margin: .1em 16px .1em 0; } 
.ui-dialog .ui-dialog-titlebar-close { position: absolute; right: .3em; top: 50%; width: 19px; margin: -10px 0 0 0; padding: 1px; height: 18px; }

comment:2 Changed 7 years ago by Scott González

Type: enhancementfeature

comment:3 Changed 7 years ago by Scott González

Component: CSS Frameworkui.dialog
Milestone: 1.9.01.10.0

comment:4 Changed 7 years ago by bavanyo

Status: newopen

comment:5 Changed 7 years ago by Jörn Zaefferer

Resolution: duplicate
Status: openclosed

Duplicate of #6832.
Closing as duplicate of #6832, as that was fixed a long time ago. Not sure why that ticket was created and referenced though, it should have pointed at this one.

Note: See TracTickets for help on using tickets.