Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6918 closed bug (fixed)

clicking slider not firing change event on other elements

Reported by: MrWillihog Owned by:
Priority: minor Milestone: 1.8.9
Component: ui.slider Version: 1.8.9
Keywords: Cc:
Blocked by: Blocking:

Description

In a simple test with 1 input box and 1 slider, a change event on the input box will not get fired when you click the slider directly after changing the input text.

Using the standard javascript onchange works, but the jQuery .change() does not.

http://jsbin.com/alife4

Change History (3)

comment:1 Changed 6 years ago by scottgonzalez

  • Status changed from new to open

The problem is that we set focus to the handle on mousedown. See http://bugs.jquery.com/ticket/8148 for the underlying bug.

comment:2 Changed 6 years ago by scottgonzalez

  • Milestone changed from 1.9 to 1.8.9
  • Resolution set to fixed
  • Status changed from open to closed

This is fixed in jQuery 1.5.2.

comment:3 Changed 6 years ago by scottgonzalez

#7307 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.