Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7307 closed bug (duplicate)

element onblur event doesnt fire when jquery slider handle is clicked instead of anywhere else on the page in firefox or chrome

Reported by: 1jason Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.slider Version: 1.8.11
Keywords: Cc:
Blocked by: Blocking:

Description

Hi there,

I have a page with a select box followed by a jquery slider. I have a simple alert that fires onblur of the select box.

What I've found in practice is that the alert only fires when the html page is clicked after the select box NOT when the slider handle is used.

Oddly, when I run this at jsfiddle, everything works as I would expect (in all browsers): http://jsfiddle.net/BxY99/2/

When I run it on a test page you can see this failure in action. http://test-psi-alpha.appspot.com/jquery

So this is quite evidently a bug in jquery (no solutions have been posted or found by me). I've since found that it only affects chrome(11) and firefox (3.6) while ie (8) is fine.

link to forum post with the same issue. (http://forum.jquery.com/topic/element-onblur-event-doesn-t-fire-when-jquery-slider-handle-is-clicked-instead-of-anywhere-else-on-the-page#14737000002239317) J

Change History (2)

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

This isn't odd that it works in jsFiddle and fails in your test page. You're using different versions of jQuery.

comment:2 Changed 9 years ago by Scott González

Duplicate of #6918.

Note: See TracTickets for help on using tickets.