Opened 8 years ago

Closed 7 years ago

#7110 closed bug (invalid)

Multiple calls to effect.scale should be based on the original %

Reported by: Corey Frang Owned by: Corey Frang
Priority: minor Milestone: 1.10.0
Component: ui.effects.* (individual effect) Version: 1.8.10
Keywords: Cc:
Blocked by: Blocking:

Description

Currently, calling scale twice on an element, if you want it to grow to 150% then back to 100% you need to do this:

$("#element").effect("scale", { percent: 150 }, 1000).effect("scale", { percent: 66 }, 1000)

The second call to scale should state percent: 100 IMO

Change History (6)

comment:1 Changed 8 years ago by Scott González

The problem I see with this is that any changes made by the user between the two calls to scale will be ignored.

comment:2 Changed 8 years ago by Corey Frang

Not necessarily - we could use .data() to store the current "percent" of the element along with some meta-information, perhaps also detecting any changes made to the properties after our animation completed before recalculating the new values...

comment:3 Changed 7 years ago by Scott González

@gnarf is this a duplicate of #7041?

comment:4 Changed 7 years ago by Scott González

Milestone: 1.9.01.10.0

comment:5 Changed 7 years ago by mikesherov

Owner: set to Corey Frang
Status: newpending

I'm fairly certain this is a dupe of #7041 as scott mentions. gnarf, any thoughts? I'm returning to pending so trac-o-bot can deal with this if you don't respond :-)

comment:6 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.