Opened 9 years ago

Closed 8 years ago

#7327 closed bug (fixed)

Dialog box size and close animation bugs

Reported by: onaiggac Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.12
Keywords: Cc:
Blocked by: Blocking:

Description

Using: jQuery 1.6

Tested: IE 8 Chrome 11 Safari 5.0.4 Firefox 4.0.1

Code tested:

	$("#body").dialog({
		height: 330,
		width: 380,
		modal: true,
		closeOnEscape: false,
		open: function(event, ui) { jQuery('.ui-dialog-titlebar-close').hide(); },
		draggable: false,
		resizable: false,
		autoOpen:false,
		show:'drop',
		hide: 'drop'
	});

Description: The dialog opens fine except for its size in: -Chrome -Safari -Firefox

When close, the dialog animation repeats 'n' times that dialog was opened. -Chrome -Safari -Firefox

Change History (2)

comment:1 Changed 9 years ago by davidmurdoch

Fixed: https://github.com/jquery/jquery-ui/pull/300

Though I couldn't reproduce the dialog size issue.

comment:2 Changed 8 years ago by David Murdoch

Resolution: fixed
Status: newclosed

Dialog: Make close() a noop if the dialog is already closed. Fixes #7327 - Dialog box size and close animation bugs.

Changeset: c7eae7b264112919462cb1b8b7ce115d3b24265d

Note: See TracTickets for help on using tickets.