Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#7362 closed bug (fixed)

Datepicker allows changing year to something outside yearRange

Reported by: ThiefMaster Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.datepicker Version: 1.8.12
Keywords: haspatch Cc:
Blocked by: Blocking:

Description

http://jsfiddle.net/ThiefMaster/hKunR/

With the next-month arrow I can easily change the year to something after 2012 (which is the max year in that example).

(tested only in Firefox)

Change History (6)

comment:1 Changed 8 years ago by fracmak

comment:2 Changed 7 years ago by Scott González

Milestone: 1.9.01.11.0

comment:3 Changed 7 years ago by mikesherov

Keywords: haspatch added
Status: newopen

comment:4 Changed 7 years ago by mikesherov

#7631 is a duplicate of this ticket.

comment:5 Changed 7 years ago by Jay Merrifield

Resolution: fixed
Status: openclosed

Datepicker: Updated the range tests so you can't navigate past the yearRange. Fixes #7362 - Datepicker allows changing year to something outside yearRange

Changeset: eca5abd873675f5cc7b96641c723b7e35a4260bc

comment:6 Changed 7 years ago by mikesherov

Milestone: 1.11.01.10.0
Note: See TracTickets for help on using tickets.