Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7427 closed enhancement (duplicate)

CSS of 1.8.13 gives a lot of validation errors

Reported by: Harm10 Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.css-framework Version: 1.8.13
Keywords: Cc:
Blocked by: Blocking:

Description

Let me start by saying that I read the respons on http://bugs.jqueryui.com/ticket/7223

I've noticed a lot of validation errors in the css for 1.8.13 And although they don't seem to influence the working of ui I still think the respons on the ticket above misses the point somewhat. There are a lot of sites around (like mine) that "proudly" state that they contain valid HTML and CSS. W3C validation buttons and all. In my view such things make your site stand out from the crowd. Using ui also contributes to this but not by adding these validation errors.

Can these errors be looked at?

Change History (3)

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

No.

comment:2 Changed 9 years ago by Scott González

Duplicate of #7223.

comment:3 in reply to:  description Changed 9 years ago by rdworth

Replying to Harm10:

I've noticed a lot of validation errors in the css for 1.8.13 And although they don't seem to influence the working of ui

Ah, but making changes suggested by validators for the sake of making the validators happy most certainly would influence the working of ui. There isn't any CSS that isn't there for a reason. If there is, it's a bug and it will be fixed, but that's not what we're talking about. This is what's meant by Scott in response to #7223 when he says "We know that the code works and is written as intended. Valid CSS is pointless if it doesn't do what you want."

I still think the respons on the ticket above misses the point somewhat.

I think the response hits the point right on the head. We don't care what css validators say. If there was a way to get the job done and not have them complain, great, but since there isn't, they'll continue to complain loudly and we'll continue to not listen.

There are a lot of sites around (like mine) that "proudly" state that they contain valid HTML and CSS. W3C validation buttons and all.

Good chance many of them also claim they use XHTML 1.1 Strict and deliver with content-type text/html to all browsers while they're at it. Which is allowed by XHTML 1.0 but not by XHTML 1.1. All of this is of very little consequence.

In my view such things make your site stand out from the crowd.

Let us stand out from the crowd as a shining beacon then.

Using ui also contributes to this but not by adding these validation errors.

Can these errors be looked at?

We don't consider them errors. We've written the code we've written according to modern best practices, in a pragmatic way. We've tested it in supported browsers and found it does what we want in the best possible way we know how. The way the code is written is a necessity, the "errors" spit out by validators against such code is noise. You can write the most pure code in the world, but if it doesn't get the job done in all the browsers that people use today, there's not much point. We're doing the best with what we've got, and what we've got is old and new browsers that aren't all perfect and standards-compliant. Making the browser happy (and the end-user as a direct result), not the validator, is our goal.

Note: See TracTickets for help on using tickets.