Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#7461 closed bug (duplicate)

checkbox button fails at retrieving elements when id contains ':' charracter

Reported by: Ankhterus Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.button Version: 1.8.13
Keywords: Cc:
Blocked by: Blocking:

Description

When id of an input element contains ':' character, ui.button works for standards buttons, but fails with checkbox buttons when retriving label elements.

See jsfiddle link for example. (tested with 1.8.13 and 1.9pre master branch) http://jsfiddle.net/gwXEU/1/

Change History (4)

comment:1 Changed 6 years ago by Scott González

#7622 is a duplicate of this ticket.

comment:2 Changed 6 years ago by tj.vantoll

This appears to have been fixed in some recent release. If I just bump up the versions of jQuery to 1.7.1 and jQuery UI to 1.8.16 in the fiddle the checkbox works just fine - http://jsfiddle.net/qt46g/1/.

comment:3 Changed 6 years ago by Scott González

Resolution: duplicate
Status: newclosed

Yeah, there was a duplicate ticket that we didn't notice.

comment:4 Changed 6 years ago by Scott González

Duplicate of #7534.

Note: See TracTickets for help on using tickets.