Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#7622 closed bug (duplicate)

bug: UI button buttonset unescaped id selector

Reported by: lahabana Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.button Version: git (not yet released)
Keywords: Cc:
Blocked by: Blocking:

Description

on jQuery UI 1.9, 1.8 and older on Chrome 13 FF 5 as reported there: http://forum.jquery.com/topic/ui-buttonset-possible-bug-with-unescaped-selector If you want to do a button set on inputs that have got complex IDs (eg: "foo::bar") Jquery fails and returns the error : "Syntax error, unrecognized expression: [for=foo::bar]" This is due to unescaped selector: https://github.com/jquery/jquery-ui/blob/master/ui/jquery.ui.button.js#L232

Change History (2)

comment:1 Changed 7 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 7 years ago by Scott González

Duplicate of #7461.

Note: See TracTickets for help on using tickets.