Opened 8 years ago

Closed 7 years ago

#7496 closed bug (fixed)

if dialog height is larger than viewport height, dialog is positioned at bottom of viewport

Reported by: gpasat Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.13
Keywords: Cc:
Blocked by: Blocking:

Description

This can be tested here as well: http://jqueryui.com/demos/dialog/ Make the browser window height smaller than the dialog would be, then click to open dialog, and dialog will position at the bottom of your window, so you would have to scroll up to see the top. Dialog should be positioned at top of window if its larger then the window. I tried setting position of the dialog after init at top if its larger than the window, but it was ignored.

Change History (11)

comment:1 Changed 8 years ago by Scott González

Resolution: worksforme
Status: newclosed

This is working properly for me, the dialog is shifted down until the dialog's titlebar is fully visible.

comment:2 Changed 8 years ago by gpasat

This does not work, I checked again in Firefox 3.6, Chrome 12 and IE 8.

When going here: http://jqueryui.com/demos/dialog. Re-size the browser to be smaller in height than the example dialog popup, then scroll the view port to the top of the Example buttons on the right. Then click "Modal message". You will get the modal popup aligned to the bottom of the browser with the top dialog title-bar cutoff.

comment:3 Changed 8 years ago by Scott González

Resolution: worksforme
Status: closedreopened

comment:4 Changed 8 years ago by Scott González

Status: reopenedopen

comment:5 Changed 8 years ago by Scott González

#7571 is a duplicate of this ticket.

comment:6 Changed 7 years ago by Scott González

Milestone: 1.9.01.10.0

comment:7 Changed 7 years ago by Jörn Zaefferer

I can't reproduce this with 1.9.2 and master. Can someone else?

comment:8 Changed 7 years ago by mikesherov

Resolution: worksforme
Status: openclosed

I can also no longer reproduce this. If someone can get a test case going on jsfiddle or JSBin or provide a clear set of reproduction steps, we'll go after it. Just reply to this ticket. For now, let's close as worksforme.

comment:9 Changed 7 years ago by tj.vantoll

I also couldn't recreate this. I tried with the version this issue was created with (1.8.13) because I was curious if this was something that was fixed and couldn't recreate the problem - http://jsfiddle.net/tj_vantoll/kJcEg/2/.

comment:10 Changed 7 years ago by Scott González

Resolution: worksforme
Status: closedreopened

Here's the fiddle that shows the problem: http://jsfiddle.net/kJcEg/3/

This was fixed in 1.9.0.

comment:11 Changed 7 years ago by Scott González

Milestone: 1.10.01.9.0
Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.