Opened 8 years ago

Closed 7 years ago

#7550 closed bug (fixed)

Autocomplete change event not triggered in time.

Reported by: garyz Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.autocomplete Version: 1.8.14
Keywords: Cc:
Blocked by: Blocking:

Description

Even though the change event is triggered on blur, it's enclosed in setTimeout with 150ms delay. If the blur is caused by a click of the submit button, then the change callback will run after the submit.

http://jsbin.com/iyiqah/5

Change History (4)

comment:1 Changed 8 years ago by Scott González

I've attempted to make the change event synchronous and it worked fine, except in IE. The problem in IE is that you can't interact with the menu at all. Hopefully we can find a way to fix this. https://github.com/scottgonzalez/jquery-ui/compare/autocomplete-syncchange

comment:2 Changed 7 years ago by Scott González

#7484 is a duplicate of this ticket.

comment:3 Changed 7 years ago by Scott González

comment:4 Changed 7 years ago by Scott González

Resolution: fixed
Status: newclosed

Autocomplete: Removed the timeout for the change event. Fixes #7550 - Autocomplete change event not triggered in time.

Thanks spekary for finding a workaround for IE.

Changeset: f5b52a89a735082d06d6f6ea950efbccff0a227f

Note: See TracTickets for help on using tickets.