Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7560 closed bug (duplicate)

this.placeholder[0].parentNode is null

Reported by: tranver Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.sortable Version: 1.8.14
Keywords: Cc:
Blocked by: Blocking:

Description

This error appears when you try to stop the sortable within the "beforeStop" event (jQuery 1.6.2 + jQuery UI 1.8.14). There's already a ticket about this issue but it's almost a year old and it looks like it has been forgotten: http://bugs.jqueryui.com/ticket/6054

this.placeholder[0].parentNode is null

Line: https://github.com/jquery/jquery-ui/blob/master/ui/jquery.ui.sortable.js#L383

Test case: http://jsfiddle.net/zVpn5/2/

Tested with the following browsers:

Google Chrome 12.0.742.122 (Windows 7)

Firefox 5.0 (Windows 7, Mac OSX)

Change History (3)

comment:1 Changed 8 years ago by tranver

Sorry, this was the incorrect line number. It's in line 1038: this.placeholder[0].parentNode (https://github.com/jquery/jquery-ui/blob/master/ui/jquery.ui.sortable.js#L1038)

Version 0, edited 8 years ago by tranver (next)

comment:2 Changed 8 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:3 Changed 8 years ago by Scott González

Duplicate of #6054.

Note: See TracTickets for help on using tickets.